Service Disruption: Mail Delays
Incident Report for rezora
Resolved
After monitoring, we can confirm that the source of the disruption has been fixed and associated mail delays have been resolved. We sincerely apologize for any inconvenience this issue may have caused and greatly appreciate your patience. Please contact our Support team at support@rezora.com with any questions.
Posted 3 months ago. Feb 02, 2019 - 11:38 MST
Investigating
A subset of our customers may be experiencing delayed mail starting at approximately 10:00pm MST, on February 1st, 2019. The cause of this issue is being investigated and we will provide updates here as they become available. We apologize for any inconvenience this may be causing you. Please contact our Support team at support@rezora.com with any questions.
Posted 3 months ago. Feb 02, 2019 - 10:26 MST
This incident affected: Distribution channels (Email deliverability).