Technical Incident: Mail Delays
Incident Report for rezora
Resolved
The source of the disruption has been fixed and mail is now caught up. We sincerely apologize for any inconvenience this issue may have caused and greatly appreciate your patience and understanding in this. Please contact our Support team at support@rezora.com with any questions.
Posted 21 days ago. Jun 28, 2019 - 12:55 MDT
Monitoring
A small subset of our customers may have experienced mail delays. A fix has already been implemented. We are currently monitoring to ensure the issue is fixed. We apologize for any inconvenience this may be causing and will provide updates as they become available. Please contact our Support team support@rezora.com with any questions.
Posted 21 days ago. Jun 28, 2019 - 11:33 MDT
This incident affected: rezora Application.