Technical Incident: Sending Delays
Incident Report for rezora
Resolved
This incident has been resolved and all delayed mail has been sent. We thank you for your patience while we addressed this issue. If you have any questions or concerns please contact our support team at support@rezora.com
Posted Aug 04, 2020 - 10:46 MDT
Identified
We have identified an issue causing some sends to be delayed in our system. We are working to correct this issue as quickly as possible and catch and delayed sends up to fully send properly. We apologize sincerely for this issue and will provide updates here as soon as they are available.
Posted Aug 04, 2020 - 10:14 MDT
This incident affected: Distribution channels (Email deliverability).