Technical Incident - sending delays
Incident Report for rezora
Resolved
Email sending is currently processing at a normal rate and delayed mail has been dequeued. We thank you for your patience while this issue was resolved. Please contact our support team at support@rezora.com with any questions or concerns.
Posted Aug 07, 2020 - 11:12 MDT
Investigating
We are investigating reports of email sends being delayed. We apologize for this issue and will provide more information as soon as it becomes available. Please contact support@rezora.com with any questions or concerns.
Posted Aug 07, 2020 - 10:43 MDT
This incident affected: Distribution channels (Email deliverability).