Contact Importer: Failure to Launch "Begin Importing"

Incident Report for rezora

Resolved

This incident has been resolved. The contact importer is opening normally and users are uploading contacts without issue.
Posted Mar 21, 2025 - 09:50 MDT

Monitoring

A fix has been implemented and we are monitoring the performance of the contact importer.
Posted Mar 21, 2025 - 07:05 MDT

Update

This is a known issue with a third-party provider. They are actively working on a fix. We will continue to update this incident as we receive updates.
Posted Mar 20, 2025 - 12:39 MDT

Identified

The issue with contact imports has been identified, and our team is working on a fix, which is expected to be completed by Friday, 3/21, though this timeline may be subject to change.
Posted Mar 20, 2025 - 11:19 MDT

Investigating

We are currently investigating reports that the "Begin Importing" button does not launch the contact importer.
Posted Mar 20, 2025 - 07:30 MDT
This incident affected: Integrations (Contact Importer).