Technical Incident: Delays in receiving emails to rezora support
Incident Report for rezora
Resolved
We have seen no further incidents of emails to our support channels becoming delayed. We will continue to keep a close eye on this to ensure we are able to meet the needs of our users in a timely fashion. If you believe your email may have been delayed and we have not gotten back to you, please contact us through live-chat by clicking the green 'help' button on the left side of your rezora page. We are marking this incident as resolved.
Posted 5 months ago. Feb 08, 2019 - 09:03 MST
Investigating
We have seen instances of some emails delivered to support@rezora.com becoming delayed by several hours. We have reached out to our support platform provider to help resolve this issue and determine if there are any inquiries that have not yet reached our support team.

We apologize terribly for any inconvenience this may have caused. If you are awaiting a response and believe your email may have not reached us yet, please come live-chat with us through the green 'help' button on the left side of your rezora page.
Posted 5 months ago. Feb 07, 2019 - 08:50 MST
This incident affected: External integrations (Support Channels).