Technical Incident: Error while adding email recipients
Incident Report for rezora
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 20, 2019 - 10:44 MST
Monitoring
We have continued to see improvements throughout the day and are no longer encountering errors when adding contacts as recipients. We will continue to monitor this incident and provide further updates as they are needed. If you are still experiencing any issues please contact our support team at support@rezora.com
Posted 9 months ago. Jan 18, 2019 - 15:55 MST
Identified
Some users are experiencing an error while adding contacts as recipients for a marketing piece. We have identified the issue and are working quickly to fix this. We will update here as soon as there is more news to share.
Posted 9 months ago. Jan 18, 2019 - 13:12 MST
This incident affected: Distribution channels (Email deliverability).