Technical Incident: Delayed Sends
Incident Report for rezora
Resolved
Our mail queue has fully caught up overnight and all emails moving forward should be sent in the normal expected amount of time.
Posted 7 days ago. Dec 05, 2018 - 09:19 MST
Monitoring
We have taken several steps to reduce the delays we have seen on sent emails. Many emails are now being sent immediately as intended, though there are some still in a queue to be processed and sent. We will continue to monitor this incident as mail de-queues. Further updates will be shared as they become available. If you have any questions or concerns, please contact us at support@rezora.com
Posted 8 days ago. Dec 04, 2018 - 15:15 MST
Identified
We have identified an issue causing delays on sending emails through rezora. Delays have been seen to potentially be multiple hours. We have allocated additional resources to clear up this issue as quickly as possible. If you have sent an email but are not seeing open metrics, or received the email yourself, please wait and do not send the piece again as this will result in a duplicate of the email being sent.

We sincerely apologize for any inconvenience this may be causing. If you have any questions please contact us at support@rezora.com
Posted 8 days ago. Dec 04, 2018 - 09:12 MST
This incident affected: rezora Application and Distribution channels (Email deliverability).